Написать программу определения числа билетов с 6-значными номерами,у которых сумма первых 3 десятичных цифр равна сумме 3 последних десятичных цифр (паскаль)
Program BB; uses crt; Var s,a,b,v,z,i:longint; Begin s:=1; {учитываем билет с номером 000000} for i:=1 to 999999 do {перебираем билеты от 000001 до 999999} begin v:=i; z:=0; while z<3 do begin z:=z+1; a:=v mod 10 +a; v:=v div 10 end; {считаем сумму последних трех чисел} while z<6 do begin z:=z+1; b:=v mod 10 +b; v:=v div 10 end; {считаем сумму первых трех чисел} if a=b then s:=s+1; a:=0; b:=0; end; writeln(s); ReadKey; end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку