j5022778
13.02.2021 00:05

Написать программу и составить блоксхему ! определить среди 3 введенных чисел сумму отрицательных и положительных.если больше сумма положительных,то найти минимум из этих 3 чисел , а иначе найти максимум.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
zanna82
28.06.2020 13:22
Uses crt;
var sump,sumn,i:integer;
a:array[1..3] of integer;
begin
for i:=1 to 3 do
begin
read(a[i]);
if a[i]>=0 then
sump:=sump+a[i]
else
sumn:=sumn+a[i];
end;
if sump>=sumn then
writeln(min(min(a[1],a[2]),min(a[2],a[3])))
else
writeln(max(max(a[1],a[2]),max(a[2],a[3])));
end.
0,0(0 оценок)
Ответ:
ntaskaeva2
28.06.2020 13:22
М...  заморила твоя задача однако
Program asd;
USES crt;
var
A:array [1..5] of integer;
min,max,min2,o,p:real;
i,n:integer;

Procedure max1;
begin
for i:=1 to 5 do
if A[i]>0 then
if min<A[i] then
min:=A[i];
Writeln('Min: ',min);
end;
Procedure min1;
begin
for i:=1 to 5 do
if A[i]<0 then
if min>A[i] then
min:=A[i];
Writeln('Min: ',min);
end;
BEGIN
clrscr;
For i:=1 to 5 do
begin
A[i]:=random(9)-5;
Write(' ',A[i]);
end;
Writeln;
//Otrizanie
For i:=1 to 5 do
if A[i]<0 then o:=o+A[i];
Writeln('Summa otrizatelnyx elementov: ',o);
//Polowitelnye
For i:=1 to 5 do
if A[i]>0 then p:=p+A[i];
Writeln('Summa polowitelnyx elementov: ',p);
if p<o then max1
else min1;
END.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота