YanaKQG
19.11.2022 22:34

решить функцию с языка программирования С++. Очень .

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
alisherpitbul
09.05.2023 22:42

В обоих заданиях нет самомого главного - не описан интерфейс с пользователем, функции пользователя и функции программы. Без этого программа не пишется. Ведь ты, по сути, формулируешь техническое задание на программирование, а в нём не должно быть неясностей для программиста, он  должен взять листочек и тупо закодировать то, что там написано.

Ну, например, по заданию 1 могут быть варианты:

1. Написать программу, которая , при этом в каждом поединке победа присуждается с вероятностью 1/3, поражение с вероятностью 1/2, ничья с вероятностью 1/6. По окончании расчетов вывести турнирную таблицу в порядке занятого места.

 

В этом случае пользователь ничего не делает и интерфейса, как такового, нет, он просто нажимает "пуск", а программа всё сама делает и выводит результаты на печать.

 

2. Написать программу, которая, при этом участники каждого турнира выводятся на экран, а пользователь сам определяет его результат(победа, ничья, поражение). По окончании турниров программа віводит турнирную таблицу в порядке занятого места.

 

В этом случае пользователь всё время в диалоге, потому что именно он должен определять результат каждого турнира.

 

Вот 2 разных сценария интерфейса к одному и тому же, что написано в задании, но программы, их сложность достаточно различаются.

 

Резюме. Если хочешь, чтобы тебе качественно а не отписались, сформулируй задания снова, лучше каждое отдельным заданием и так, чтобы тебе самой было понятно, что ты хочешь от программы.

Успехов!

 

0,0(0 оценок)
Ответ:
Nastya6376
13.10.2022 00:17
Составим программку:

uses Crt;
const n=20;
type Mas=array [1..n, 1..n] of integer;
var A: Mas;
    i,k, Sum: integer;
begin
ClrScr;
Sum:=0;
for i:=1 to  n do
  begin
  for k:=1 to n do
     begin
      if i>k then
             begin
                A[i,k]:=1;
                Sum:=Sum+A[i,k];
             end
             else
             begin
                A[i,k] :=-1;
                Sum:=Sum+A[i,k];
             end;
      Write(A[i,k]:3);
     end;
  WriteLn;
  end;
  WriteLn;
  WriteLn(' Sum = ',Sum);
ReadLn;
end.

Эта программа симметрично относительно главной диагонали заполняет массив единичками с плюсом или минусом и считает сумму диагональных элементов.
Если n=20, то Sum = -20
Если n = 100, то Sum = - 100
ПРАВИЛЬНЫЙ ОТВЕТ:      3) - 100
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота