shavkatbronduk1
27.02.2023 07:13

. Написать программу в С. Сформулируйте динамічний одновимірний масив, у якому 15 елементів, заповніть його випадковими числами та виведіть на друк. Оформіть генерацію і виведення масиву за до функції користувача. Реалізуйте цю програму за до операцій new та delete.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
bon332
30.05.2023 15:03

1. Створіть функцію для генерації масиву випадкових чисел.

2. Створіть функцію для виведення масиву на екран.

3. Створіть функцію main, яка буде викликати функції для генерації та виведення масиву.

4. Використовуйте оператор new для створення динамічного масиву.

5. Використовуйте оператор delete для звільнення пам'яті, виділеної для масиву.

Ось приблизний код для генерації масиву випадкових чисел:

c++

#include <iostream>

#include <cstdlib>

#include <ctime>

using namespace std;

void generateArray(int *arr, int size) {

srand(time(NULL)); // ініціалізуємо генератор випадкових чисел

for (int i = 0; i < size; i++) {

arr[i] = rand() % 100; // генеруємо числа в діапазоні 0-99

}

}

void printArray(int *arr, int size) {

for (int i = 0; i < size; i++) {

cout << arr[i] << " ";

}

cout << endl;

}

int main() {

int size = 15;

int *arr = new int[size]; // створюємо динамічний масив

generateArray(arr, size); // заповнюємо масив випадковими числами

printArray(arr, size); // виводимо масив на екран

delete[] arr; // звільняємо пам'ять, виділену для масиву

return 0;

}

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота