bryaaa
24.02.2020 04:25

3. Напишите программу, в которой вычисляются сумма, разность, произведение, частное и среднее арифметическое двухцелых чисел, введенных с клавиатуры.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
altay2007
03.07.2022 17:28
Var n,m,osn: integer;
function nmbdec(var n,osn: integer): integer;
var nmb,l,s,k: integer;
begin
  nmb:=0;  s:=0;
  k:=n;  l:=1;
  while k>0 do
  begin
    s:=k mod 10;
    k:=k div 10;
    nmb:=nmb+l*s;
    l:=l*osn;
  end;
  Result:=nmb;
end;
{ конец функции}
begin
  write('число:  ');
  readln(n);
  write('квадрат какого числа:  ');
  readln(m);
  osn:=10;
  while osn>=2 do
  begin
     osn:=osn-1;
    if nmbdec(n,osn)=sqr(nmbdec(m,osn)) then
    begin
      writeln('основание системы = ',osn);
      break;
    end;
  end;
end.
0,0(0 оценок)
Ответ:
Nurbibi12
03.05.2021 10:07
Const
  problems : array [0..9] of String = ('x1+5=10', 'x1+5=10', 'x1+5=10', 'x1+5=10', 'x1+5=10', 'x1+5=10', 'x1+5=10','x1+5=10', 'x1+5=10', 'x1+5=10');
  answers : array [0..9] of String = ('-5', '-5', '-5', '-5', '-5', '-5', '-5', '-5', '-5', '-5');
var
  countOfAnswers, counter: integer;
  userAnswer: String;
begin
  countOfAnswers := 0;
  for counter:=0 to 9 do
    begin
      write('Введите ответ уравнения ', problems[counter], ' : ');
      readln(userAnswer);
      if userAnswer = answers[counter] then Inc(countOfAnswers);
    end;
if countOfAnswers > 8 then writeln('Отлично')
    else if countOfAnswers > 5 then writeln('Хорошо')
    else writeln('Плохо');
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота