konkina
11.09.2022 17:41

Напишите программу для вывода 5-ти случайных чисел в диапазоне от 10 до 10000

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
SKoteickaЗ
12.01.2023 12:22

Напомним основные свойства степени. Пусть а > 0, b > 0, n, m - любые действительные числа. Тогда

1) an am = an+m

2) anam=an−manam=an−m

3) (an)m = anm

4) (ab)n = an bn

5) (ab)n=anbn(ab)n=anbn

6) an > 0

7) an > 1, если a > 1, n > 0

8) an < am, если a > 1, n < m

9) an > am, если 0< a < 1, n < m

В практике часто используются функции вида y = ax, где a - заданное положительное число, x - переменная. Такие функции называют показательными. Это название объясняется тем, что аргументом показательной функции является показатель степени, а основанием степени — заданное число.

Определение. Показательной функцией называется функция вида y = ax, где а — заданное число, a > 0, a≠1a≠1

Показательная функция обладает следующими свойствами

1) Область определения показательной функции — множество всех действительных чисел.

Это свойство следует из того, что степень ax где a > 0, определена для всех действительных чисел x.

2) Множество значений показательной функции — множество всех положительных чисел.

Чтобы убедиться в этом, нужно показать, что уравнение ax = b, где а > 0, a≠1a≠1, не имеет корней, если b⩽0b⩽0, и имеет корень при любом b > 0.

3) Показательная функция у = ax является возрастающей на множестве всех действительных чисел, если a > 1, и убывающей, если 0 < a < 1.

Это следует из свойств степени (8) и (9)

Построим графики показательных функций у = ax при a > 0 и при 0 < a < 1.

Использовав рассмотренные свойства отметим, что график функции у = ax при a > 0 проходит через точку (0; 1) и расположен выше оси Oх.

Если х < 0 и |х| увеличивается, то график быстро приближается к оси Oх (но не пересекает её). Таким образом, ось Ох является горизонтальной асимптотой графика функции у = ax при a > 0.

Если х > 0 и |х| увеличивается, то график быстро поднимается вверх.

График функции у = ax при 0 < a < 1 также проходит через точку (0; 1) и расположен выше оси Ох.

Если х > 0 и увеличивается, то график быстро приближается к оси Ох (не пересекая её). Таким образом, ось Ох является горизонтальной асимптотой графика.

Если х < 0 и |х| увеличивается, то график быстро поднимается вверх.

 

Показательные уравнения

Рассмотрим несколько примеров показательных уравнений, т.е. уравнений, в которых неизвестное содержится в показателе степени. Решение показательных уравнений часто сводится к решению уравнения ax = ab где а > 0, a≠1a≠1, х — неизвестное. Это уравнение решается с свойства степени: степени с одинаковым основанием а > 0, a≠1a≠1 равны тогда и только тогда, когда равны их показатели.

Решить уравнение 23x • 3x = 576

Так как 23x = (23)x = 8x, 576 = 242, то уравнение можно записать в виде 8x • 3x = 242, или в виде 24x = 242, откуда х = 2.

ответ х = 2

Решить уравнение 3х + 1 - 2 • 3x - 2 = 25

Вынося в левой части за скобки общий множитель 3х - 2, получаем 3х - 2(33 - 2) = 25, 3х - 2 • 25 = 25,

откуда 3х - 2 = 1, x - 2 = 0, x = 2

ответ х = 2

Решить уравнение 3х = 7х

Так как 7x≠07x≠0 , то уравнение можно записать в виде 3x7x=13x7x=1, откуда (37)x=1(37)x=1, х = 0

ответ х = 0

Решить уравнение 9х - 4 • 3х - 45 = 0

Заменой 3х = t данное уравнение сводится к квадратному уравнению t2 - 4t - 45 = 0. Решая это уравнение, находим его корни: t1 = 9, t2 = -5, откуда 3х = 9, 3х = -5.

Уравнение 3х = 9 имеет корень х = 2, а уравнение 3х = -5 не имеет корней, так как показательная функция не может принимать отрицательные значения.

ответ х = 2

Решить уравнение 3 • 2х + 1 + 2 • 5x - 2 = 5х + 2х - 2

Запишем уравнение в виде

3 • 2х + 1 - 2x - 2 = 5х - 2 • 5х - 2, откуда

2х - 2 (3 • 23 - 1) = 5х - 2( 5 2 - 2 )

2х - 2 • 23 = 5х - 2• 23

(25)x−2=1(25)x−2=1

x - 2 = 0

ответ х = 2

Решить уравнение 3|х - 1| = 3|х + 3|

Так как 3 > 0, 3≠13≠1, то исходное уравнение равносильно уравнению |x-1| = |x+3|

Возводя это уравнение в квадрат, получаем его следствие (х - 1)2 = (х + 3)2, откуда

х2 - 2х + 1 = х2 + 6х + 9, 8x = -8, х = -1

Проверка показывает, что х = -1 — корень исходного уравнения.

ответ х = -1

 

Объяснение:

вот это правильно

0,0(0 оценок)
Ответ:
temirlan2019p
04.11.2021 16:02

1. ключевое слово "for" написано неправильно(For)

2. вместо str нужно написать range

3. убрать апострофы в скобках.

4. ключевое слово print написано неправильно

5. перед 2-ой строкой должен стоять отступ(в виде 4-х пробелов)

6. вместо M нужно написать i

Объяснение: вот как я вижу правильную программу:

for i in range(1000,0,-200):

   print(i)

P.s. ко второму и третьему пункту: здесь на самом деле зависит от целей программы, если программа выводит некоторые элементы из строки str(переменной, которая была объявлена до показаного кода), то там приписали не нужные скобки(не нужно также их содержимое). Иначе, если программа собирается вывести:

1000

800

600

400

200

0

(что наиболее вероятно). тогда вместо str нужно написать range и убрать апострофы в скобках.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота