kafmmi
20.02.2022 21:41

Тема: Двумерные массивы в С/C++ Mассив вывести на экран в виде таблицы без разделительных линий. Правее массива в колонку вывести значения той характеристики двумерного массива, которая находится для каждой строки.Ниже массива вывести значения той характеристики двумерного массива, которая находится для каждого столбца.

Массив типа int размером 8 строк по 7 столбцов. Найти: сумму четных элементов для всего массива; количество элементов, не кратных 3, в каждой строке; минимум в каждом столбце.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
trokhymukjulia
03.05.2020 10:55

Объяснение:

Т.к. я не знаю, как ты реализовал первую часть программы, скидываю тебе своё решение этой задачи целиком:

numbers_list = []

while True:

   numbers = int(input("Введите число: "))

   if numbers == 0:

       break

   else:

       numbers_list.append(numbers)

sum_numbers = sum(numbers_list)

my_dict = {}

for x, y in enumerate(numbers_list):

   if y % 3 == 0:

       my_dict[x] = y  # Замени на my_dict[x+1] = y, если надо считать с 1

print(f"Сумма всех введенных чисел: {sum_numbers}")

print(f"Словарь из чисел, кратных 3: {my_dict}")

Значит, смотри:

Создаём пустой лист. Далее вводим числа в бесконечном цикле, пока не получим 0 и складываем их в лист.

Затем, получаем сумму всех чисел при функции sum().

Потом создаём пустой словарик. И в цикле перебираем наш список с цифрами, используя enumerate (), чтобы получать индекс этого числа (то бишь, порядковый номер). Обрати внимание, что номер будет начинаться с нуля. Т.е. если тебе надо с 1, то просто в my_dict[x] = y поменяй на my_dict[x+1] = y и всё.

Ну и проходясь по списку с числами, мы проверяем каждое число, делится ли оно на 3 и если да, то добавляем в словарь. Где его ключ - это индекс, а значение - само число.

Пример работы программы, разумеется, прилагаю.


Python Напишите программу, которая запрашивает у пользователя число до тех пор, пока он не введет ци
0,0(0 оценок)
Ответ:
nastyagrng
08.05.2022 05:59

1. 134 бит

2. 1419264 бит

3. 6,21 Тбайт

4. 2764,8 Мбайт

5. 0,542 Мбайт

6. 4456448 байт

7. 0,0000277 Мбайт

8. 2147483648 бит

Объяснение:

1 байт = 8 бит

1 Кбайт = 1024 байт

1 Мбайт = 1024 Кбайт

1 Гбайт = 1024 Мбайт

1 Тбайт = 1024 Гбайт

1. Сколько бит содержится в 16,75 байтах?

16,75 байт = 16,75 * 8 = 134 бит

2. Сколько бит содержится в 173,25 килобайтах?

173,25 Кбайт = 173,25 * 1024 = 177408 байт = 177408 * 8 = 1419264 бит

3. Сколько терабайтов содержится в 6363 гигабайтах?

6363 Гбайт = 6363 / 1024 ≈ 6,21 Тбайт

4. Сколько мегабайтов содержится в 27,5 гигабайтах?

27,5 Гбайт = 27,5 * 1024 = 2764,8 Мбайт

5. Сколько мегабайтов содержится в 568328 байтах?

568328 байт = 568328 / 1024 ≈ 555,008 Кбайт = 555,008 / 1024 = 0,542 Мбайт

6. Сколько байтов содержится в 4,25 мегабайтах?

4,25 Мбайт = 4,25 * 1024 = 4352 Кбайт = 4352 * 1024 = 4456448 байт

7. Сколько мегабайт информации содержит сообщение объемом 232 бит

232 бит = 232 / 8 = 29 байт = 29 / 1024 ≈ 0,028 Кбайт = 0,028 / 1024 ≈ 0,0000277 Мбайт

8. Сколько бит информации содержит сообщение объемом 256 мегабайт

256 Мбайт = 256 * 1024 = 262144 Кбайт = 262144 * 1024 = 268435456 байт = 268435456 * 8 = 2147483648 бит

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота