kpilipaka02
27.04.2021 23:16

Сделать в паскале. составьте программу, которая удаляет из слова x те буквы, которые встречаются в слове z. слова x и z вводятся с клавиатуры.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
levonaleqsanya
28.06.2020 01:16
var
x,z:string;
i:integer;
ar:array['а'..'я'] of boolean;
begin
readln(x);
readln(z);

for i:=1 to Length(z) do
  ar[z[i]]:=true;
  for i:=Length(x) downto 1 do
    if (ar[x[i]] = true) then delete(x,i-1,1);   
writeln(x);
end.

Не забудь отметить лучший ответ ;-)
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота