SirykValia
09.07.2021 03:52

Напишите программу в паскале по этим заданиям


Напишите программу в паскале по этим заданиям
Напишите программу в паскале по этим заданиям
Напишите программу в паскале по этим заданиям

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Прив26789
26.03.2023 12:37

1)

Function check7(a As Range) As Integer

Dim r As Range

Dim i As Integer

For Each r In a

i = i + 1 - Sgn((Abs(r) + 3) Mod 10)

Next

check7 = i

End Function

Excel VBA

2)

А что здесь программировать-то?

Задача сводится к с следующей: Дано два ящика и 7 мячиков. Сколькими можно разместить эти 7 мячиков в этих двух ящиках?

Бросаем все мячики в первый ящик (это первое размещение), затем перекладываем по одному мячика из первого ящика во второй.

Получаем варианты:

7|0

6|1

5|2

4|3

3|4

2|5

1|6

Итого 7 вариантов (варианта 0|7 быть не может, поскольку двузначное число с нуля не начинается).

В общем-то и без вычислений всем очевидно, что разместить 7 мячиков в двух ящиков ровно 7.

Что должна вычислять программа?

0,0(0 оценок)
Ответ:
Metalmekid
01.06.2022 20:55
Var a: byte; b:integer;
Begin 
writeln('Введите день месяца');
readln(b);
writeln('Введите номер месяца');   
Readln(a);    
          Case a of        
1: writeln(b,' янавря');        
2: writeln(b,' февраля');      
3: writeln(b,' марта ');        
4: writeln(b,' апреля ');      
5: writeln(b,' мая');      
6: writeln(b,' июня ');        
7: writeln(b,' июля');       
8: writeln(b,' августа');     
9: writeln(b,' сентября');     
10: writeln(b,' октября');     
11: writeln(b,' ноября');       
12: writeln(b,' декабря');     
else writeln('Месяца №', a,'нет');   
end;       
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота