shkuratov89525510021
21.02.2020 18:48

Напишите программу которая переводит число из 2-9 системы счисления в 10 на паскале


Напишите программу которая переводит число из 2-9 системы счисления в 10 на паскале

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Shaurma021
22.03.2022 13:40

Program From2To10;

var

n2: Longint;

n10, m, i: Integer;

begin

Write('n2 = ');

ReadLn(n2);

n10 := 0;

m := 1;

while n2 <> 0 do

begin

i := n2 mod 10;

n10 := n10 + i * m;

m := m * 2;

n2 := n2 div 10;

end;

WriteLn('n10 = ', n10);

end.

n2 - исходное число в двоичной записи

n10 - число в десятичной записи

m - 2 в степени номер разряда цифры

i - очередная цифра

Объяснение:

Вроде так

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота