Violetta291
19.03.2020 14:25

Составить программу для решения задачи: Даны два слова. Определить, в котором из них букв "а" больше. Сделать либо через функцию, либо через процедуру. Язык программирования Паскаль.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
hashedhashed1
14.12.2020 23:23

ответ (перепроверьте на всякий случай скобки, вроде должно быть всё верно, но там довольно замороченно, лучше ещё раз перепроверить):

from math import atan,log

a = [0.5, -1, -2]

b = [1.5, 0.5, 0]

p = [-4, -4, -4]

while True:

 try:

   x = float(input('Введите x: '))

   break

 except ValueError:

   print('Вводите число!')

if abs(x) < 0.2:

 for i in range(3):

   print(f'Вариант {i+1}: {a[i]**2 * x**3 + (b[i]**4 + 1.7)**0.5}')

elif abs(x) == 0.2:

 for i in range(3):

   print(f'Вариант {i+1}: {atan(2**x - abs(p[i]))}')

else:

 for i in range(3):

   print(f'Вариант {i+1}: {(log(abs(a[i])) + 4.3)**(1/3) + x}')

"Попроще" - без циклов, проверки ввода и массивов:

from math import atan,log

a1 = 0.5

a2 = -1

a3 = -2

b1 = 1.5

b2 = 0.5

b3 = 0

p1 = -4

p2 = -4

p3 = -4

x = float(input('Введите x: '))

if abs(x) < 0.2:

 y = a1**2 * x**3 + (b1**4 + 1.7)**0.5

 print('Вариант 1: ', y)

 y = a2**2 * x**3 + (b2**4 + 1.7)**0.5

 print('Вариант 2: ', y)

 y = a3**2 * x**3 + (b3**4 + 1.7)**0.5

 print('Вариант 3: ', y)

elif abs(x) == 0.2:

 y = atan(2**x - abs(p1))

 print('Вариант 1: ', y)

 y = atan(2**x - abs(p2))

 print('Вариант 2: ', y)

 y = atan(2**x - abs(p3))

 print('Вариант 3: ', y)

else:

 y = (log(abs(a1)) + 4.3)**(1/3) + x

 print('Вариант 1: ', y)

 y = (log(abs(a2)) + 4.3)**(1/3) + x

 print('Вариант 2: ', y)

 y = (log(abs(a3)) + 4.3)**(1/3) + x

 print('Вариант 3: ', y)

0,0(0 оценок)
Ответ:
chcuvivhcyxu
09.02.2020 08:29
Червь  – программа, которая делает копии самой себя. Ее вред заключается в захламлении компьютера, из-за чего он начинает работать медленнее. Отличительной особенностью червя является то, что он не может стать частью другой безвредной программы.Троянская программа (троянский конь, троян)Троянская программа маскируется в других безвредных программах. До того момента как пользователь не запустит эту самую безвредную программу,  троян не несет никакой опасности. Тронская программа может нанести различный ущерб для компьютера. В основном трояны используются для кражи, изменения или удаления данных. Отличительной особенностью трояна является то, что  он не может самостоятельно размножаться.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота