mikimaus4
17.02.2022 23:33

Python У Саши на компьютере есть папка, где он хранит все свои фото для будущих публикаций. У каждого фото в этой папке есть особое название - семизначный номер.

В этом номере каждая цифра обозначает актуальность фото для определенной аудитории. Сейчас Саша хочет разделить семизначное число на цифры и выписать их в столбик с текстовыми пометками "популярно" (если число больше или равно 7) или "мимо" (если число меньше 7).

Формат входных данных
Семизначное целое положительное число N.

Формат выходных данных
Все цифры числа, начиная с единиц, каждое в отдельной строке. Рядом с цифрой слово "популярно" или "мимо" (в зависимости от цифры).

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
KathrynMay
21.03.2022 12:40

n = int(input())

while n:

   a = n % 10

   s = 'популярно' if a >= 7 else 'мимо'

   print(a, s)

   n //= 10

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота