Maximp190302
23.06.2020 22:55

4. Напишите программный код для следующей задачи: (46) Даны 3 числа. Нужно найти наименьшее из них и вывести значение на результат. Составьте программу вложенных условий на языке программирования Python.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Остап1843
22.12.2021 17:22
Данная программа выполнена для PascalABC.net, немного кривая, но полностью рабочая. 

uses GraphABC;
var i:integer;

Procedure Boy(z,w:integer);
begin
rectangle(z-20,w-30,z+20,w+40);
MoveTo(z-20,w-20);
LineTo(z-35,w+15);
LineTo(z-20,w);
LineTo(z-20,w-20);
Floodfill(z-25,w,clBrown);
MoveTo(z+20,w-20);
LineTo(z+35,w+15);
LineTo(z+20,w);
LineTo(z+20,w-20);
Floodfill(z+25,w,clBrown);
Floodfill(z,w,clBlue);
MoveTo(z-10,w+40);
LineTo(z-10,w+70);
LineTo(z-3,w+70);
LineTo(z-3,w+40);
LineTo(z+3,w+40);
LineTo(z+3,w+70);
LineTo(z+10,w+70);
LineTo(z+10,w+40);
LineTo(z-10,w+40);
Floodfill(z-5,w+65,clBrown);
Floodfill(z+5,w+65,clBrown);
Circle(z,w-40,20);
Floodfill(z,w-40,clBrown);
end;

Procedure Ball(x,y:integer);
begin
circle(x,y,15);
floodfill(x,y,clRed);
end;

begin
lockdrawing;
for i:=1 to 20 do begin
boy(100,200);
Ball(100+i*5,200-i*5);
ellipse(200,115,250,140);
RedRaw;
ClearWindow(clWhite);
end;
for i:=1 to 5 do begin
boy(100,200);
Ball(200+i*5,100+i*5);
ellipse(200,115,250,140);
RedRaw;
ClearWindow(clWhite);
end;
for i:=1 to 25 do begin
boy(100,200);
Ball(225,125+i*5);
ellipse(200,115,250,140);
RedRaw;
ClearWindow(clWhite);
end;
end.
0,0(0 оценок)
Ответ:
marien2
30.05.2020 17:02
Если программа нужна на паскале, то вот держите

program ArrayZ;
uses CRT; // Подключение модуля CRT
var  z: array[1..4, 1..3] of integer; // Массив  i, j, n, o: integer;// Переменные для циклов и счета отрицательных и нечетных элементов
begin  randomize; // Нужно для turbopascal  // Заполнение массива  for i := 1 to 4 do  begin    writeln; // Переход на другую строку    for j := 1 to 3 do    begin      z[i, j] := random(60) - 30; // Рандомное заполнение массива      write(z[i, j]:8); // Вывод в консоль массива    end;  end;  // Нахождение отрицательных и нечетных элементов  for i := 1 to 4 do    for j := 1 to 3 do    begin      if z[i, j] mod 2 <> 0 then // Нахождение нечетных элементов        n := n + 1;      if z[i, j] < 0 then // Нахождение отрицательных элементов        o := o + 1;    end;   writeln; // Переход строки чтобы не было конфликтов  writeln('Нечетных элементов: ', n, ' | Отрицательных элементов: ', o); // Вывод результатаend.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота