nevidomskyamarg
21.01.2020 23:15

Чтобы реализовать программу, нужно создать какие объекты-виджеты надо

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Dima1Tap
04.04.2023 10:26
Летающий автобус)
1. Мест в эконом-классе 120, а в бизнес-классе 40.
2. 100 процентов прибыли получим, если заполним все места. Билет в эконом-классе стоит в 2 раза меньше чем X. Получаем следующее уравнение:
40*X + 0.5*120*X = 100%, X = 1% от всей прибыли.  Значит один билет в бизнес - классе приносит один процент прибыли. А один билет в эконом-классе приносит 0.5 процента прибыли.
3. Осталось рассчитать прибыль компании учитывая непроданные билеты:
P = 100 - b - 0.5*a  и написать программу:

var a,b:integer;
begin
  repeat
    writeln('Введите количество непроданных билетов (a,b)');
    readln(a,b);
  until (a<=120) and (b<=40)and (a>=0) and (b>=0);
  writeln('Прибыль компании составит ',100-b-0.5*a,'%');
end.

 
0,0(0 оценок)
Ответ:
vany4189
04.04.2023 10:26
Летающий автобус)
1. Мест в эконом-классе 120, а в бизнес-классе 40.
2. 100 процентов прибыли получим, если заполним все места. Билет в эконом-классе стоит в 2 раза меньше чем X. Получаем следующее уравнение:
40*X + 0.5*120*X = 100%, X = 1% от всей прибыли.  Значит один билет в бизнес - классе приносит один процент прибыли. А один билет в эконом-классе приносит 0.5 процента прибыли.
3. Осталось рассчитать прибыль компании учитывая непроданные билеты:
P = 100 - b - 0.5*a  и написать программу:

var a,b:integer;
begin
  repeat
    writeln('Введите количество непроданных билетов (a,b)');
    readln(a,b);
  until (a<=120) and (b<=40)and (a>=0) and (b>=0);
  writeln('Прибыль компании составит ',100-b-0.5*a,'%');
end.

 
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота