Svetbor04
06.08.2021 19:47

3. Дана последовательность чисел от 0 до 20. Напишите программу, которая вычисляет сумму чисел до 6. [5]

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
ukaldarbek206
14.04.2020 16:07
Что касается конкретной программы
1. Описываем нужные нам переменные - это будут стороны прямоугольника a и b. Поскольку нигде ничего о размерах сторон не сказано, придется предположить, что они не обязательно будут целыми , мы опишем эти переменные, как вещественные (real), что позволит работать и с нецелыми значениями.
2. Из геометрии нам известны формулы периметра прямоугольника P=2 x (a+b) и площади прямоугольника S=a x b. Можно описать переменные P, S (тоже real), но смысла в этом нет, поскольку значения P и S нужны только для вывода результатов, так что проще написать нужные выражения непосредственно в операторе вывода.
3. Итак, с описанием переменных закончили, можно начинать основную программу ключевым словом begin. И сразу же пишем к нему завершающий end с точкой на конце - таковы правила языка Паскаль. Вся программа размещается между двумя этими ключевыми словами.
4. Сначала организуем ввод. Это два оператора. Первый оператор выводит так называемое "приглашение" - сообщает о том, что нужно ввести. Второй оператор - это сам ввод.
5. А теперь, как было сказано выше, организуем вывод результатов. Все это сделает один оператор вывода. Программа готова!

var
  a, b: real;

begin
  Write('Введите стороны прямоугольника: '); Readln(a, b);
  Writeln('Периметр равен ', 2 * (a + b), ', площадь равна ', a * b)
end.

Тестовое решение:
Введите стороны прямоугольника: 4 3.16
Периметр равен 14.32, площадь равна 12.64
0,0(0 оценок)
Ответ:
софи157
30.12.2022 10:01
Последовательность действий ученика при самостоятельном изучении параграфа учебника:
1) достать учебник
2) сесть за стол
3) открыть учебник
4) прочитать параграф
5) ответить на вопросы после параграфа
6) открыть тетрадь
7) сделать краткий конспект по вопросам в конце параграфа
8) закрыть тетрадь
9) закрыть учебник
10) убрать учебник

Последовательность действий мамы при варке манной каши:
1) взять кастрюлю
2) налить воду в кастрюлю
3) зажечь огонь на плите
4) поставить кастрюлю на огонь
5) достать крупу, молоко
6) добавить в кастрюлю молоко
7) когда вода и молоко закипят добавить крупу
8) взять ложку
9) мешать ложкой крупу
10) накрыть крышкой
11) выключить огонь под кастрюлей
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота