tataynka1
08.12.2022 21:55

c++ Напишите программу, которая вычисляет и выводит, сколько километров отделяют космическую станцию от Земли, если              радиосигнал, распространяющийся в пространстве со скоростью 300 000 км/с, достигает Земли через 8,5 ч.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
nikzyk
14.02.2020 18:33

var

  a: 1000..9999;  //четырехзначное число

  a1, a2, a3, a4: 1..9;  {цифры четырехзначного числа (цифры могут быть только от 1 до 9 в десятичной системе счисления)}

 

begin

  writeln('Введите четырехзначное число');

  readln(a);  //Вводим четырехзначное число

  a1:= a div 1000;  {Находим первую цифру, для этого делим это число без остатка на 1000 (например пусть число будет 5479, тогда получится 5479 / 1000 = 5,479; отбрасываем остаток и получается 5)}

  a2:= (a mod 1000) div 100;  {Находим вторую цифру, для этого сначала берем остаток от деления этого числа на 1000, а потом делим результат на 100 без остатка (5479 / 1000 = 5,479; оставляем остаток, получается 479; 479 / 100 = 4,79 ; отбрасываем остаток и получается 4)}

  a3:= (a mod 100) div 10;  {Находим 3 цифру, для этого сначала берем остаток от деления этого числа на 100, а потом делим результат на 10 без остатка (5479 / 100 = 54,79; берем остаток и получается 79; 79 / 10 = 7,9 ; отбрасываем остаток и получается 7)}

  a4:= a mod 10;  {Для нахождения 4 цифры берем остаток от деления этого числа на 10 (5479 / 10 = 547,9 ; берем остаток и получается 9)}

  writeln('Сумма цифр числа ', a, ' равна:  ', a1 + a2 + a3 + a4);  {Выводим сумму цифр}

end.

Если все правильно, отметь решение как лучшее)

  

   

0,0(0 оценок)
Ответ:
Zzz111zzz15zz888zz
12.07.2020 22:43


Ведь под знаком принято понимать цифры и числа, буквы и слова человеческого языка. А то, что от первого взгляда на глиняную табличку рябит в глазах от треугольных элементов ещё не значит, что всё так однозначно. 
"...Старейшая из известных систем письма – клинопись (т.е. клинообразное письмо, англ. cuneiform от латинского cuneus "клин") возникла не позже 3100 до н.э. и находилась в употреблении примерно до начала нашей эры. Сначала клинописное письмо было в ходу у шумеров – народа с высокоразвитой культурой, но с неизвестными этническими и языковыми корнями... Ее использовали для записи своих собственных языков хетты в Анатолии, хурриты, жившие на территории современной Сирии и северного Ирака, эламцы на западе Ирана и урартцы в Армении... Число знаков в клинописи менялось в течение всей ее истории, но примерно их было всего 600, из них 100–150 были слоговыми знаками..."

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота