yoeru
08.02.2022 10:57

Составьте программу позволяющую перевести полученные в процентах в пятибалльную систему


Составьте программу позволяющую перевести полученные в процентах в пятибалльную систему

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
alexalex251003
06.03.2023 13:51
Program fgg;

var
x: String[10];
t, v, s: Real;

begin
Write('Что будем искать?: ');
ReadLn(x);
if x = 'скорость' then
begin
Write('Введите расстояние: ');
ReadLn(s);
Write('Введите время: ');
ReadLn(t);
WriteLn('Скорость=', s / t);
end
else if x = 'время' then
begin
Write('Введите расстояние: ');
ReadLn(s);
Write('Введите скорость: ');
ReadLn(v);
WriteLn('Время=', s / v);
end
else if x = 'расстояние' then
begin
Write('Введите скорость: ');
ReadLn(v);
Write('Введите время: ');
ReadLn(t);
WriteLn('Расстояние=', v * t);
end
else
WriteLn('Неверно указано, что будем искать.');
end.
0,0(0 оценок)
Ответ:
Кристи626
28.10.2020 14:36
num_1 = int(input("Введіть 1 число: "))
diya_1 = input("Введіть дію: ")
num_2 = int(input("Введіть 2 число: "))
diya_2 = input("Введіть дію: ")
num_3 = int(input("Введіть 3 число: "))
if diya_1 == '/':
if diya_2 == '/':
print(num_1,'/',num_2,'/',num_3,'= ', num_1/num_2/num_3)
if diya_2 == '*':
print(num_1,'*',num_2,'/',num_3,'= ', num_1*num_2/num_3)
if diya_2 == '-':
print(num_1,'-',num_2,'/',num_3,'= ', num_1-num_2/num_3)
if diya_2 == '-':
print(num_1,'+',num_2,'/',num_3,'= ', num_1+num_2/num_3)

if diya_1 == '+':
if diya_2 == '*':
print(num_1,'+',num_2,'*',num_3,'= ', num_1+num_2*num_3)
if diya_2 == '/':
print(num_1,'+',num_2,'/',num_3,'= ', num_1+num_2/num_3)
if diya_2 == '+':
print(num_1,'+',num_2,'+',num_3,'= ', num_1+num_2+num_3)
if diya_2 == '-':
print(num_1,'+',num_2,'-',num_3,'= ', num_1+num_2-num_3)

if diya_1 == '*':
if diya_2 == '+':
print(num_1,'*',num_2,'+',num_3,'= ', num_1*num_2+num_3)
if diya_2 == '-':
print(num_1,'*',num_2,'-',num_3,'= ', num_1*num_2-num_3)
if diya_2 == '/':
print(num_1,'*',num_2,'/',num_3,'= ', num_1*num_2/num_3)
if diya_2 == '*':
print(num_1,'*',num_2,'*',num_3,'= ', num_1*num_2*num_3)

if diya_1 == '/':
if diya_2 == '-':
print(num_1,'/',num_2,'/',num_3,'= ', num_1/num_2/num_3)
if diya_2 == '+':
print(num_1,'*',num_2,'+',num_3,'= ', num_1/num_2+num_3)
if diya_2 == '*':
print(num_1,'-',num_2,'*',num_3,'= ', num_1/num_2*num_3)
if diya_2 == '-':
print(num_1,'+',num_2,'-',num_3,'= ', num_1/num_2-num_3)
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота