rebecca332
20.02.2021 17:15

Напишите программу на с++, желательно без вектора Введите матрицу 5x5 целых чисел от 0 до 9. Если количество повторов
элемента матрицы совпадает с самим элементом, то заменить его на нуль

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Мишка12лэд
12.02.2023 16:34

double a, a1;

           ConsoleKeyInfo keyInfo;

           do

           {

               Console.Write("Введите число: ");

               a = Convert.ToDouble(Console.ReadLine());

               a1 = Math.Pow(a, 2);

               Console.WriteLine("Квадрат числа "+ a + " = " + a1);

               a1 = Math.Pow(a, 3);

               Console.WriteLine("Куб числа " + a + " = " + a1 + "\n");

               Console.WriteLine("Если хотите повторить программу нажмите F");

               Console.WriteLine("Если хотите завершить программу нажмите любую другую кнопку\n");

               keyInfo = Console.ReadKey(true);

           }

           while (keyInfo.Key == ConsoleKey.F);


Пользователь вводит число. Программа выводит на экран квадрат этого числа, куб этого числа.
0,0(0 оценок)
Ответ:
bubnovasofya20
26.02.2021 18:50

double a, b, c, s;

           ConsoleKeyInfo keyInfo;

           do

           {

               Console.Write("Введите первое число: ");

               a = Convert.ToDouble(Console.ReadLine());

               Console.Write("Введите второе число: ");

               b = Convert.ToDouble(Console.ReadLine());

               Console.Write("Введите третье число: ");

               c = Convert.ToDouble(Console.ReadLine());

               a *= 2;

               Console.WriteLine("\n"+a);

               b -= 3;

               Console.WriteLine(b);

               c = Math.Pow(c,2);

               Console.WriteLine(c+"\n");

               s = a + b + c;

               Console.WriteLine("Сумма: " + s+"\n");

               Console.WriteLine("Если хотите повторить программу нажмите F");

               Console.WriteLine("Если хотите завершить программу нажмите любую другую кнопку\n");

               keyInfo = Console.ReadKey(true);

           }

           while (keyInfo.Key == ConsoleKey.F);


Пользователь вводит три числа. Увеличьте первое число в два раза, второе числа уменьшите на 3, треть
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота