djastin05
16.03.2023 15:29

Написать программу в Паскале для построения графика функций. К программе желательно составить алгоритм )

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
saksharovsasha
14.08.2020 11:02

 2)

var i:integer;
begin
writeln('Введите цифру означающюю день недели, например 2-вторник');
readln(i);
case i of
1:writeln('Понедельник: Алгебра,Геометрия,Русский,Физ-ра');
2:writeln('Вторник Информатика,История,Изо');
3:writeln('Среда,Английский,Искусство');
else writeln('ERROR');

readln;
end;

3)

var a:integer;
begin
writeln('Введите ваш возраст');
readln(a);
if (a<7) then writeln('Дошкольник') else
if (a>7) and (a<18) writeln('Ученик') else
if (a>18) and (a<60) writeln('Рабтник') else
if (a>65) writeln('Пенсионер');
readln;
end.

 

 

 

 

 

 

 

 

 

 


 

 

 

 

 

 

 

0,0(0 оценок)
Ответ:
Karina3589
14.08.2020 11:02
Pascal:
var n,m:longint;
      f:boolean;
begin
  write ('Decimal: ');
  readln(n);
  write ('Number: ');
  readln (m);
  f:=true;
  while (n<>0) do
  begin
    if ((n mod 10)=m) then
      begin
       f:=true;
       break;
      end;
    n:=n div 10;
  end;
  if f then writeln ('YES!') else writeln ('NO');
  readln;
end.

C++:
#include <iostream>
using namespace std;

int main()
{
  int n,m;
  bool f = false;
  cout <<"Decimal: ";
  cin >>n;
  cout <<"Number: ";
  cin >>m;
  while (n!=0)
  {
    if ((n%10)==m)
    {
      f = true;
      break;
    }
    n/=10;
  }
  if (f)
    cout <<"YES!" <<endl;
  else cout <<"NO!" <<endl;
  return 0;
}
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота