olyakak00Fokcu
16.09.2022 15:05

Дан массив из 20 элементов, заполненный случайными целыми числами из интервала [-10, 10]. Выведите этот массив в строку и найдите наибольший элемент среди четных элементов массива

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Sino4ka
25.02.2022 10:00

Программа:

Pascal:

const n = 20;  // кол-во элементов в массиве

var

 arr: array[1..n] of integer;

 i, maxEven: integer;

begin

 maxEven := -MAXINT;  // для будущего поиска минимального числа

 write('Массив: ');

 for i := 1 to n do

 begin

   arr[i] := random(-10, 10);  // заполнение случайными числами от -10 до 10

   write(arr[i], ' ');  // вывод элемента

   if arr[i] mod 2 = 0 then  // если число чётное, то...

     maxEven := arr[i];  // установить значение переменной maxEven, равное текущему макс.элементу

 end;

 

 writeln(#13, 'Максимальный чётный элемент: ', maxEven);

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота