Адриана1111111
06.06.2020 00:39

В массиве хранится информация о стипендии 30 учащихся группы. Возможны варианты:
85 бел руб, если средний успеваемости от 5 до 5.9, а также в первом семестре
102 бел руб, если средний успеваемости от 6 до 7.9
119 бел руб - если средний успеваемости от 8 до 8.9
137 бел руб - если средний успеваемости от 9 до 10
составьте программу, которая определяет, получает ли в этом семестре, хотя бы один учащийся максимальную стипендию, и если да, то выведите количество таких учащихся

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
nocitronum
30.10.2021 03:42

#include <iostream>

#include <string>

#include <algorithm>


bool P(int value)

{

   std::string left = std::to_string(value);

   std::reverse(left.begin(), left.end());

   std::string right = std::to_string(value);;

   return left == right;

}


int main()

{

   int n;

   std::cin >> n;


   int count = 0;

   for (int i = 1; i <= n; ++i)

   {

       if (P(i))

       {

           count++;

       }

   }


   std::cout << "Count palindrome: " << count << std::endl;

   return 0;

}

0,0(0 оценок)
Ответ:
пророк2345
01.01.2023 18:36
1)
var a:string;
    i, o: Integer;
    p: Real;
begin
     readln(o);
     a := inttostr(o);
     for i := 1 to length(a) do
        p := p + strtoint(a[i]);
     if (sqr(o) = p*p*p) then writeln('true')
        else writeln('false');
end.

2)
var a:string;
    i, o, p: Integer;
begin
     readln(o);
     a := inttostr(o);
     for i := 1 to length(a) do
        p := p + strtoint(a[i]);
     if (p mod 3 = 0) then writeln('true')
        else writeln('false');
end.

3)
var a, b, c: real;
begin
     readln(a, b, c);
     if ((a = b) and (b = c)) then writeln('true')
        else writeln('false');
end.

Всё проверено, удачи:)
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота