sashdjfjfh
13.08.2022 21:26

Написать программу на с# Зал Большого театра столь велик, что артистам при выступлении необходимо иметь радиомикрофоны.

В начале и конце спектакля все артисты находятся за кулисами. Артисты выходят на сцену и покидают сцену через правую или левую кулису, при этом артист берет с собой один микрофон. Уйдя со сцены, артист оставляет микрофон за той кулисой, через которую он ушел.

Имеется режиссерский план, в котором для каждого артиста указано его прихода и ухода со сцены, а также то, через какие кулисы он входит и выходит.

Определите, какое наименьшее число микрофонов необходимо приготовить режиссеру за каждой кулисой до начала спектакля.

Формат входных данных
Первая строка входный данных содержит натуральное число n, 1<=n<10000. Далее идет n строк – инструкции для артистов. Каждая строка состоит из двух чисел и двух букв. Первое число – время выхода артиста от начала спектакля в секундах, второе число – время ухода артиста со сцены. Потом идет одна из двух букв "l" или "r" в зависимости от того, через какую кулису (левую или правую) приходит артист и еще одна буква, указывающая через какую кулису уходит артист. Например, строка "300 500 l r" означает, что актер выходит на сцену в момент времении 300 через левую кулису и уходит со сцены в момент 500 через правую кулису.

Времена приходов и уходов – целые неотрицательные числа, не превосходящие 10000. Строки во входном файле могут идти в произвольном порядке, не обязательно упорядоченные по времени. Если в один и тот же момент один артист уходит за кулису, а другой выходит из-за этой же кулисы, то он может передать ему микрофон в этот момент.

Формат выходных данных
Программа должна вывести два числа: минимальное количество микрофонов, которое должно быть в начале спектакля за левой и за правой кулисами.

Пример
Входные данные:
3
0 100 l r
50 150 l l
100 200 r l
Выходные данные
2 0

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Andruha321
24.03.2021 10:04

//Обьявляем дополнительные переменные и главный массив, а также два дополнительных - они будут "половинками".

var

 a, b, c: array [1..100] of longint;

 i, min, n, j, t: longint;

begin

 //Читаем количество элементов в нашем массиве.

 readln(n);

 

 //Читаем массив.

 for i := 1 to n do read(a[i]);

 

 //Заполняем первую "половинку".

 for i := 1 to n div 2 do b[i] := a[i];

 

 //Заполняем вторую "половинку". Но раз это уже вторая "половинка" главного массива, то и

 //цикл теперь должен начинаться со второй части массива, а заканчиваться уже в его конце.

 for i := n div 2 + 1 to n do c[i - n div 2] := a[i];

 

 //Теперь отсортируем первую "половинку" методом выбора. Идея этого метода

 //основывается на том, что мы ищем минимальный среди неотсортированных элемент,

 //а затем аем его с тем, который стоит сразу после отсортированных.

 for i := 1 to (n - 1) div 2 do

 begin

   min := i;

   for j := i + 1 to n div 2 do

     if b[min] > b[j] then

       min := j;

   if min <> i then begin

     t := b[i];

     b[i] := b[min];

     b[min] := t;

   end;

 end;

 

 //Затем вторую точно также, только стоит обратить внимание на сравнения.

 //Так как надо отсортировать по убыванию, то теперь сравнение перед "swap"-ом

 //будет другим.

 for i := 1 to (n - 1) div 2 do

 begin

   min := i;

   for j := i + 1 to n div 2 do

     if c[min] < c[j] then

       min := j;

   if min <> i then begin

     t := c[i];

     c[i] := c[min];

     c[min] := t;

   end;

 end;

 

 //А теперь по очереди выводим готовые "половинки", не забывая ставить

 //пробел после вывода каждого элемента.

 for i := 1 to n div 2 do write(b[i], ' ');

 for i := 1 to n - n div 2 do write(c[i], ' ');

end.

0,0(0 оценок)
Ответ:
577656
22.09.2021 03:24

За последние 20 лет уровень применения компьютеров в медицине чрезвычайно повысился. Практическая медицина становится все более и более автоматизированной. Существует множество программ для компьютеров.

Выделяют два вида компьютерного обеспечения: программное и аппаратное. Программное обеспечение включает в себя системное и прикладное.

Системное программное обеспечение предназначено для функционирования самого компьютера как единого целого. Это, в первую очередь, операционная система, а также сервисные программы различного назначения - драйверы, утилиты и т. п. В системное программное обеспечение входит сетевой интерфейс, который обеспечивает доступ к данным на сервере. Данные, введенные в компьютер, организованы, как правило, в базу данных, которая, в свою очередь, управляется прикладной программой управления базой данных (СУБД) и может содержать, в частности, истории болезни, рентгеновские снимки в оцифрованном виде, статистическую отчетность по стационару, бухгалтерский учет.

Прикладное обеспечение представляет собой программы, для которых, собственно, и предназначен компьютер. Это - вычисления, обработка результатов исследований, различного рода расчеты, обмен информацией между компьютерами и т. д.

Сложные современные исследования в медицине немыслимы без применения вычислительной техники. К таким исследованиям можно отнести компьютерную томографию, томографию с использованием явления ядерно-магнитного резонанса, ультрасонографию, исследования с применением изотопов. Количество информации, которое получается при таких исследования так огромно, что без компьютера человек был бы не ее воспринять и обработать.

Очень важным в последнее время становится использование компьютеров, объединенных в компьютерные сети при специальных кабелей или телефонных каналов. Такие компьютерные сети позволяют очень эффективно производить обмен данными между удаленными друг от друга компьютерами. В рамках Российского Министерства Здравоохранения и медицинской промышленности функционирует компьютерная сеть MEDNET, которая позволяет упростить сбор статистических медицинских данных по регионам, делать соответствующую обработку, агрегирование данных и составление отчетности. Кроме того, эта сеть позволяет передавать любые данные между медицинскими учреждениями, имеющими компьютеры. В последнее время также получили распространение компьютерные гипертекстовые системы, которые позволяют таким образом организовать информацию, что она становится легко доступной для людей, не являющихся специалистами в компьютерном деле. Такие гипертекстовые системы могут включать в себя как текстовую информацию, так и звуковую и графическую, в том числе, движущиеся видеоизображения. Это позволяет создавать информационные системы, осуществляющие информационную поддержку медиков в тех случаях, когда их квалификации или опыта недостаточно для принятия решений о комплексе лечебных мероприятий, например, на догоспитальном этапе. Эти же системы, оснащенные подсистемой вопросов и оценки ответов, могут использоваться для целей обучения.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота