21122007
28.04.2021 02:40

Дан целочисленный массив из 30-ти элементов.написать программу,которая позволит найти среднее арифметическое положительных элементов массива .

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
avalak99
27.06.2020 01:33
Паскаль:

var mas : array[1..30] of longint;
n,i : longint;
r : real;
begin
 for i:=1 to 30 do read (mas[i]);
 n:=30; r:=0;
 for i:=1 to 30 do begin
  if mas[i]<1 then begin mas[i]:=0; n:=n-1;
  r:=r+mas[i];
 end;
 writeln(r/n);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота