Ychi1ka
22.12.2022 10:59

Ребят кто шарит плз Опишите термин «Одномерный массив».
……………………………………………………………………………………………………….
….……………………………………………………………………………………………………
Приведите пример одномерного массива.
……………………………………………………………………………………………………….
….……………………………………………………………………………………………………

Прочитайте условия задач и напишите программный код.
Дана строка, состоящая из слов, разделенных пробелами. Определите, сколько в ней слов.
Дана строка, в которой буква K встречается несколько раз. Определите общее количество буквы K в строке.
Найти номер минимального по модулю элемента массива. Например, в массиве [10, -3, -5, 2, 5] минимальным по модулю элементом является число 2. Его номер 4 (в языках, в которых индексация массивов начинается с нуля, его индекс будет равен 3).
Найти сумму всех элементов массива. Например, если дан массив [12, 90, 4, 8, 10]
В одномерном массиве найти сумму элементов, находящихся между минимальным и максимальным элементами. Сами минимальный и максимальный элементы в сумму не включать

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
evasyperandreev
15.02.2022 11:00

Все выполняется на Python

Объяснение:

Пример массива: [0, 2, 5, 10]

s = "///"                            #Тут какая-то строка, состоящая из слов

1) Есть много посчитать, один из них:

a = s.split(" ")

print(len(a))

2) count = 0

for i in s:

   if i == "K":

       count += 1

print(count)     // это, если важно, что буква заглавная.  Если нет, то поменяйте if i == "K":     на   if i == "K" or i == "k":

3) s = [///] - массив, заполненный числами

minim = 100000

ind = 0

for i in range(len(s)):

   if s[i] < 0:

       s[i] *= -1

for i in range(len(s)):

   if s[i] < minim:

       minim = s[i]

       ind = i

print(ind)

4) sum = 0

for i in range(len(s)):

   sum += s[i]

print(sum)

5) Такой себе код получился, но работает

s = [-100, -3, -5, 2, 5, -15]

minim = 100000

maxim = -100000

ind1 = 0

ind2 = 0

sum = 0

for i in range(len(s)):

   if s[i] > maxim:

       maxim = s[i]

       ind1 = i

for i in range(len(s)):

   if s[i] < minim:

       minim = s[i]

       ind2 = i

for i in range(len(s)):

   if ind1 < i < ind2:

       sum += s[i]

for i in range(len(s)):

   if ind2 < i < ind1:

       sum += s[i]

print(sum)

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота