nikitakoshelevozt3ef
20.02.2020 14:48

Напишите программу, которая заполняет массив 5 случайными целыми числами на отрезке [10,100], выводит этот массив на экран и считает сумму все нечетных элементов массива.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
zdiana1
02.06.2020 00:37
Задача №1

var a:array[1..3, 1..4] of integer; 
i,j,min:integer; 
begin 
for i:=1 to 3 do 
for j:=1 to 4 do begin 
read(a[i,j]); 
if a[i,j]<0 then min:=a[i,j]; 
end; 
for i:=1 to 3 do 
for j:=1 to 4 do 
if (a[i,j]<0) and (a[i,j]<min) then min:=a[i,j]; 
writeln('Минимальное отрицательное число ',min); 
end.

Задача №2
var a:array[1..2, 1..5] of integer; 
i,j:integer; 
begin 
for i:=1 to 2 do 
for j:=1 to 5 do read(a[i,j]); 
for i:=1 to 2 do begin 
for j:=1 to 5 do 
write(a[i,j],' '); 
writeln; 
end; 
end. 

Задача №3
var a:array[1..3, 1..4] of integer; 
i,j:integer; 
begin 
for i:=1 to 3 do 
for j:=1 to 4 do read(a[i,j]); 
for i:=1 to 3 do 
for j:=1 to 4 do 
if a[i,j]=10 then writeln('Номер столбца — ',j,' Номер строки — ',i); 
end. 
0,0(0 оценок)
Ответ:
protasovarsenip0a3kn
01.10.2021 12:24
Давай попробуем рассуждать логически.
Если бы сад состоял из двух деревьев, то было бы два варианта садов: 100+99 и 100+101. Если бы досадили третье дерево, то каждый из предыдущих садов удвоил бы число вариантов: первый 100+99+98 и 100+99+100, и так же второй 100+101+100 и 100+101+102. Подмечаем закономерность: каждое добавляемое дерево удваивает количество вариантов. А сад из одного дерева имеет лишь один вариант.

Поэтому ответ: 1 * 2 * 2 * 2 * ... (десять двоек умножаются) = 2^10 = 1024 варианта садов. 

Думаю что так, если не напутал. Но ты лучше проверь за мной. 
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота