ЮлияБогинская
06.05.2022 13:38

(составить программу по pascal) дано двузначное число. определить, кратна ли сумма его цифр 6. подсказка: нужно отделить от числа единицы и десятки. чтобы узнать, сколько десятков в числе, нужно поделить число нацело на 10. результат присвоить какой-нибудь переменной. затем исходное число поделить с команды mod на 10 и результат записать в другую переменную.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
kseniahas7
26.06.2020 22:55
Program zad6;
var n, d, e, s: integer;
begin
readln (n);
d:=n div 10;
e:= n mod 10;
s:=d+e;
if s mod 6=0 then writeln (' сумма цифр числа кратна 6') else  writeln (' сумма цифр числа  не кратна 6');
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота