lionlioness
16.07.2020 12:29

Изучи предложенный программный код и определи возможную ошибку при вычислении арифметического выражения.
a = int(input('Enter 1st number: '))
b = int(input("Enter 2st number: '))
s = 2 * a / 2
принт(с)
возможно деление на положительное число
возможно деление на ноль
ошибки не возникает
возможно деление на отрицательное число

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
werty13pl16
30.05.2023 02:15
1) Системный блок
2) один из самых важных, особенно для тех, кто всерьёз решил освоить профессию программиста. Мы изучаем понятие подпрограмм и функций в программировании. В Scratch нет этих понятий, но есть возможность создавать Другие блоки. Это и есть прямой аналог подпрограмм. Подумай, что по-твоему, значит термин подпрограмма. Внимательно слушай объяснения учителя. И ты убедишься, что это совсем не сложно, а даже наоборот — удобно. С других блоков (подпрограмм) мы научимся делать код короче и понятнее, то есть оптимальнее. Вперёд! Успехов!
0,0(0 оценок)
Ответ:
Maksim3131
20.12.2020 21:25

Объяснение:

#include <iostream>

#include <vector>

using namespace std;

int main()

{

   setlocale(LC_ALL, "Russian");

   int m,n;

   cin >> m >> n;// размер матрицы m*n, где m - количество столбцов

   vector<vector<int>> a(m, vector<int>(n,0));

   for (int i = 0; i < m; i++) {

       for (int j = 0; j < n; j++) {

           cin >> a[i][j];//заполнение матрицы

       }

   }

   cout << endl;

   cout << "Введите A и B"<<endl;

   int A, B;

   cin >> A >> B;

   for (int i = 0; i < n; i++) {

       int summ = 0,counter=0;

       for (int j = 0; j < m; j++) {

           if (A<= a[j][i] && B>=a[j][i]) {

               summ += a[j][i];

               counter++;

           }

       }

       cout << endl;

       cout << "В " << i+1<<" столбце:"<<endl;

       cout <<"сумма чисел, попавших на интервал [" << A << "," << B << "] " <<", равна " <<summ<<";"<<endl;

       cout <<"количество чисел, попавших на интервал ["<<A<<","<<B<<"], "<< counter<<"."<<endl;

   }

}

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота