Допишите программу на языке паскаль


Допишите программу на языке паскаль

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
dauren1mukumov
13.05.2020 17:43
Задача 7. ВОДОЛАЗКА
Задача 2. после 6 применений 64 четных цифры (после каждого применения их количество увеличивается в 2 раза)
Задача 1. не может быть Даша второй, т.к. это утверждение в 4 и 5 строках. Не может быть третьей Ира (предполагается в 3 и 5 строках). Значит первая Маша. А Даша и Ира - не призеры. Из 4-й строки получаем. что и Боря не призер. Из 1 и 3 строки получаем, что Вася - не призер (т.к. указано что Вася второй и Вася третий). Значит призер Таня (не первая и не третья, значит - вторая). Из 2 строки получаем, что и Гена не призер. Остается Антон - третий
ответ: Маша, Таня, Антон
Задача 3. Всего можно составить  60 трехзначных чисел. Числе. меньших 200, 12. Вероятность 12/60=0,2
Задача 9. 16
Задача 4. Можно (Земля-Марс-юпитер-Венера-Меркурий)
Задача 6.
370
343
640
613
910
901
271
253
550
 
0,0(0 оценок)
Ответ:
mariyaIvanowwwna
25.11.2022 22:04

Задание 2, 3 во вложении

Объяснение:

Задание 1.

Сначала вводятся переменные b и с через пробел.

Мы вводим сначала с, оно равно 205, и затем b, оно равно 204.

затем идет условие.

Если с>b или b mod 2=0

Если 205>204 или

b mod 2=0 - это означает, число b кратно 2, то есть при делении на 2 оно должно дать 0.

В нашем случае 204/2=102 , то есть число 204 кратно 2, оно поделилось на него без остатка.

Первое и второе условие сработало, а значит выполняется следующее:

a:=b+2;

То есть в переменной а мы к b прибавляем 2. И у нас выходит:

a:=204+2=206

Условие иначе у нас не работает, поэтому выводим:

Writeln(a);

Программа выведет число а

206.


1)Чему равно значение а после выполнения программы, если с=205 b=204 Var a,b,c: integer; Begin Read
1)Чему равно значение а после выполнения программы, если с=205 b=204 Var a,b,c: integer; Begin Read
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота