Skillet121516
03.08.2021 06:23

Создайте алгоритм для Кумира


Создайте алгоритм для Кумира

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
xuimorjovi
29.08.2020 13:57
1) Выводит 2
2)
var
    N: longint;
    digit, maxdigit: integer;

begin
    readln(N);
    maxdigit := 10; // нужно присваивать 0
    while N > 10 do // нужно написать N > 0
    begin
        digit := N mod 10;
        if digit > maxdigit then
            maxdigit := digit;
        N := N div 10;
    end;
    writeln(digit); // нужно вывести maxdigit
end.

Верный код

var
    N: longint;
    digit, maxdigit: integer;

begin
    readln(N);
    maxdigit := 0;
    while N > 0 do
    begin
        digit := N mod 10;
        if digit > maxdigit then
            maxdigit := digit;
        N := N div 10;
    end;
    writeln(maxdigit);
end.

Требовалось написать программу при выполнении которой с клавиатуры считывается натуральное число n,
0,0(0 оценок)
Ответ:
amina24569
29.08.2020 13:57
1) При вводе числа 256 программа выведет 3, т.к.
ввели n=256
n>0 ? - да, значит дальше идёт блок из цикла, и будет он повторятся до тех пор пока n будет >0.
d:=256 mod 10
d:=6, т.к. mod берёт остаток от деления.
n:=256 div 10
n:=25, т.к. div делит нацело и остаток не берёт.
sum:=sum+1;
sum:=1;

цикл первый раз закончился и опять проверяется условие n>0, если да, то опять запускает цикл. n:=25>0
d:=25 mod 10
d:=5
n:=25 div 10
n:=2
sum:=1+1
sum:=2;

опять закончился цикл и проверяется условие n>0, n:=2>0
d:=2 mod 10;
d:=2;
n:=2 div 10
n:=0
sum:=2+1;
sum:=3;

заканчивается цикл и проверяется условие n>0? n:=0 >0 - нет. цикл заканчивается и выводится значение sum.
ответ: 3.
2) 120, 210, 111 и т.д.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота