shluhiNovokrai
23.05.2022 11:26

Составить программу проверки кратности числа 5. (Pascal)

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
аннушка2935
12.04.2023 06:15

а) 1111₂ < 1111₈

б) 10101₂ < 10111₂

в) А99₁₆ > 999₁₆

г) 11010₂ = 32₈

Объяснение:

а) 1111₂ и 1111₈

1111₂ = 1 * 2³ + 1 * 2² + 1 * 2¹ + 1 * 2⁰ = 8 + 4 + 2 + 1 = 15₁₀

1111₈ = 1 * 8³ + 1 * 8² + 1 * 8¹ + 1 * 8⁰ = 512 + 64 + 8 + 1 = 585₁₀

15₁₀ < 585₁₀

1111₂ < 1111₈

б) 10101₂ и 10111₂

10101₂ = 1 * 2⁴ + 0 * 2³ + 1 * 2² + 0 * 2¹ + 1 * 2⁰ = 16 + 4 + 1 = 21₁₀

10111₂  = 1 * 2⁴ + 0 * 2³ + 1 * 2² + 1 * 2¹ + 1 * 2⁰ = 16 + 4 + 2 + 1 = 23₁₀

21₁₀ < 23₁₀

10101₂ < 10111₂

в) А99₁₆ и 999₁₆

А99₁₆ = А * 16² + 9 * 16¹ + 9 * 16⁰ = 10 * 256 + 9 * 16 + 9 * 1 = 2560 + 144 + 9 = 2713₁₀

999₁₆ = 9 * 16² + 9 * 16¹ + 9 * 16⁰ = 9 * 256 + 9 * 16 + 9 * 1 = 2304 + 144 + 9 = 2457₁₀

2713₁₀ > 2457₁₀

А99₁₆ > 999₁₆

г) 11010₂ и 32₈

11010₂ = 1 * 2⁴ + 1 * 2³ + 0 * 2² + 1 * 2¹ + 0 * 2⁰ = 16 + 8 + 2 = 26₁₀

32₈ = 3 * 8¹ + 2 * 8⁰ = 24 + 2 = 26₁₀

26₁₀ = 26₁₀

11010₂ = 32₈

0,0(0 оценок)
Ответ:
pycya2006
09.05.2023 13:28
Var
  x,y:real;
begin
  Write('Введите координаты x и y точки: '); Readln(x,y);
  Write('Точка с указанными координатами ');
  if not ((y<=x) and (x<=2) and ((sqr(x)+sqr(y))>=4) and (y>=0)) then
    Write('не ');
  Writeln('принадлежит заштрихованной области.')
end.

Примеры выполнения программы:
Введите координаты x и y точки: 1.9 2.1
Точка с указанными координатами не принадлежит заштрихованной области.

Введите координаты x и y точки: 1.9 1.82
Точка с указанными координатами принадлежит заштрихованной области.

Введите координаты x и y точки: 1 -3
Точка с указанными координатами не принадлежит заштрихованной области.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота