Составить программу : "Мои любимые фильмы"
(список из 10 фильмов).
Можно выбрать вместо фильмов что-нибудь другое
(фото или скриншот программы)

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
bagira2912
23.11.2020 23:53

-32768 .. 32768 (кроме 0)

Объяснение:

16 битами можно закодировать 2^{16}=65536 различных значений.

По условию кодируются положительные и отрицательные числа в равном количестве, так что и тех и других половина, по 65536 : 2 = 32768 чисел.

Получается диапазон -32768 .. 32768, из которого убрали нуль.

Обычно всё же ноль в представлениях целых чисел есть. Если использовать прямой код для записи чисел, то получится как раз одинаковое количество положительных и отрицательных чисел, но два нуля (положительный и отрицательный). Для этого случая диапазон будет -32767..32767.

0,0(0 оценок)
Ответ:
Андрей20531
27.10.2021 20:51

В первой четверти (x > 0, y > 0) заштрихована четверть окружности с началось в центре координат и радиусом 6. Уравнение этой окружности x^2+y^2=36, тогда точка попадает в заштрихованную область, если x^2+y^2. Сюда же можно добавить и отрезок от 0 до 6 по оси абсцисс.

В четвертой четверти (x > 0, y < 0) заштрихован треугольник. Граница проходит через точки (0, -6) и (6, 0), уравнение - линейная функция y = x - 6. Сюда будут попадать точки, для которых y > x - 6.

Собираем условия вместе и можно писать программу.

Код (PascalABC.NET):

begin

 var (x, y) := ReadReal2;

 if (x > 0) and (y >= 0) and (x * x + y * y < 36) then

   write('true')

 else if (x > 0) and (y < 0) and (y > x - 6) then

   write('true')

 else

   write('false')

end.

Код (Python 3):

x, y = map(float, input().split())

if x > 0 and y >= 0 and x * x + y * y < 36:

   print('true')

elif x > 0 and y < 0 and y > x - 6:

   print('true')

else :

   print('false')

Пример ввода:

3 5

Пример вывода:

true

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота