1Asya111
31.01.2020 21:26

Программа получает на выход действительное положительное число. определите количество десятков в числе

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
denisst105
23.09.2020 23:20
Программа, которая использует два массива

var 
c, a: array[1..20] of integer; 
i: integer;
begin 
write('Первый массив '); 
for i := 1 to 20 do   begin   
c[i] := i * (-5);   
write(c[i], ' '); 
end; 
writeln; 
write('Преобразованный массив '); 
for i := 1 to 20 do   begin   
a[i] := c[20 - i + 1];   
write(a[i], ' '); 
end;  
end.

ИЛИ  Программа не использующая два массива, а просто переворачивающая первый

var 
c: array[1..20] of integer; 
i: integer;
begin  write('Первый массив '); 
for i := 1 to 20 do   begin   
c[i] := i * (-5);   
write(c[i], ' '); 
end; 
writeln; 
write('Преобразованный массив '); 
for i := 20 downto 1 do  write(c[i], ' '); 
end.

Обе программы работают!
0,0(0 оценок)
Ответ:
228УЕБАН228
01.08.2021 14:08

//PascalABC.NET

uses GraphABC;

var  c: integer;

begin

 window.IsFixedSize := true;//запрет изменения размера экрана

 window.Clear(cllightblue);//очистка экрана синим цветом

 pen.Color := clred;//меняем цвет пера на красный

 for var i := 0 to 19 do//цикл для отрисовки линий

 begin

   c := (window.Height div 19) * i;//сдвиг линнии по y

   line(0, 0 + c, window.Width, window.Height - c);//рисуем линию

 end;

end.

Объяснение:

uses graphabc;

begin

circle(50,50,50);

circle(50,50,20);

circle(150,50,50);

circle(150,50,20);

circle(250,50,50);

circle(250,50,20);

circle(350,50,50);

circle(350,50,20);

circle(450,50,50);

circle(450,50,20);

circle(550,50,50);

circle(550,50,20);

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота