BNN11
12.01.2020 09:02

. надо составить программу на языке Пайтон. которая пишет все возможные варианты числа. например 451 154. 541.514 и.т.д.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Alya23051
30.12.2021 21:42

Адекватная версия:

PascalABC.NET

begin

 var expr := Readstring();

 expr.Split(' ')[0].Println;

end.

Версия "Нас так учили"

var  

expression: string;

s_index: byte;

begin

 s_index := 1;

 readln(expression);

 while expression[s_index] <> ' ' do begin

   write(expression[s_index]);

   s_index := s_index + 1;

 end;  

 

end.

Объяснение:

Т.к по условию слово - последовательность непробельных символов, ограниченная пробелами или концами строки, то данная программа полностью игнорирует пунктуацию и считает любой символ частью того слова, с которым он не разделён пробелом.

0,0(0 оценок)
Ответ:
MSZaDrotE
30.12.2021 21:42

Адекватная версия:

PascalABC.NET

begin

 var expr := Readstring();

 expr.Split(' ')[0].Println;

end.

Версия "Нас так учили"

var  

expression: string;

s_index: byte;

begin

 s_index := 1;

 readln(expression);

 while expression[s_index] <> ' ' do begin

   write(expression[s_index]);

   s_index := s_index + 1;

 end;  

 

end.

Объяснение:

Т.к по условию слово - последовательность непробельных символов, ограниченная пробелами или концами строки, то данная программа полностью игнорирует пунктуацию и считает любой символ частью того слова, с которым он не разделён пробелом.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота