Minecraftserver34
21.02.2020 20:58

Спрограммой в паскале, дан массив из n чисел. определить количество чисел, превышающих число 5. найти сумму этих чисел. напишите программу.. (одномерный массив)

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
annaoroku3
26.06.2020 16:53
Program arr;
var 
 ar : array[1..100] of Integer; 
 i, size, count, sum : Integer;
begin 
 Writeln('Введите размер массива');
 Readln(size); 
 if (size > 100) then begin 
  Writeln('Hазмер массива превышает 100 элементов. Программа будет завершена...');   
 Readln; 
 end 
 else begin 
  Writeln('Введите ', size, ' чисел');   
 for i:=1 to size do begin     
 readln(ar[i]);     
 if ar[i] > 5 then begin       
 Inc(count);       
 Inc(sum, ar[i]);     
 end;   
 end;   
 Writeln('Вы ввели ', i - 1, ' чисел из которых ', count, ' больше 5, а их сумма составляет ', sum);   
 Readln; 
 end;
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота