аленагут1
31.01.2021 16:53

Строки в стиле С •Написать программу, которая вводит символьный массив из 15-ти или
меньшего числа элементов и находит в нем символ с наименьшим ASCII-кодом

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
3ka9ty1a99
31.01.2022 01:00

#include <stdio.h>

#include <windows.h>

#include <string.h>

#define _MAX_STRING_SIZE_ 15

int main()

{  

   SetConsoleCP(65001);

   

   char str [_MAX_STRING_SIZE_];

   scanf("%s", &str);

   int min = (int)str[0];

   for(int i = 0; i < strlen(str); i++)

       if((int)str[i] < min)

           min = (int)str[i];

   printf("%d", min);

   return 0;

}

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота