jasmine9
12.01.2020 16:45

1. Напишите программу, которая находит сумму и произведение двух целых чисел, введённых с клавиатуры.
Например, при вводе чисел 4 и 7 мы должны получить ответ
4+7=11
4*7=28

2. Ввести число, обозначающее количество секунд. Вывести то же са-мое время в минутах и секундах.
Пример:
Введите число секунд: 175
2 мин. 55 с

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
vasdehinskil
30.01.2022 06:10

print("Ноль в качестве знака операции"

     "\nзавершит работу программы")

while True:

   s = input("Знак (+,-,*,/): ")

   if s == '0':

       break

   if s in ('+', '-', '*', '/'):

       x = float(input("x="))

       y = float(input("y="))

       if s == '+':

           print("%.2f" % (x+y))

       elif s == '-':

           print("%.2f" % (x-y))

       elif s == '*':

           print("%.2f" % (x*y))

       elif s == '/':

           if y != 0:

               print("%.2f" % (x/y))

           else:

               print("Деление на ноль!")

   else:

       print("Неверный знак операции!")

Объяснение:

* ето множить / делить

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота