vytriskoivan
10.01.2021 18:10

Написать программу, которая получает на 10 элементов и записывает их в массив. Также программа получает на вход число. Необходимо посчитать сколько раз это число встречается в массиве.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Stukaneva
28.01.2022 08:20

Відповідь:

#include <iostream>

using namespace std;

const int size = 10;

void cinarr(int *arr,const int size){

int counter = 1;

for(int i = 0; i < size; i++){

 cout << "Введите " << counter << " елемент массива: ";

 cin >> arr[i];

 counter++;

}

}

void printarr(int *arr, const int size){

for(int i = 0; i < size; i++){

 cout << arr[i] << " ";

}

}

int expression(int *arr,const int size,int number){

int counternumber = 0;

for(int i = 0; i < size; i++){

 if(number == arr[i]){

  counternumber++;

 }

}

return counternumber;

}

int main(){

setlocale(LC_ALL , "Rus");

int number;

cout << "Введите число которое будем искать: ";

cin >> number;

int *arr = new int [size];

cinarr(arr,size);

printarr(arr,size);

cout << "\nТаких чисел в массиве: " << expression(arr,size,number) << endl;;

delete [] arr;

return 0;

}

Пояснення:


Написать программу, которая получает на 10 элементов и записывает их в массив. Также программа получ
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота