Kinder1644
27.05.2022 01:35

Домашнє завдання No7 Курс:
Програмування на Python
ТЕМА: Робота з рядками Завдання 1
Ви перебуваєте в квест-кімнаті мультфільму WALL-E! Щоб вибратися з кімнати, необхідно виконати такі кроки:
1. Дізнайтеся довжину рядка s наведеного тексту і виведіть це значення в консоль.
2. Виведіть весь текст в нижньому регістрі.
3. Хтось припустився помилки і некоректно написав ім'я робота WALL-E! Замініть всі входження слова WALLE на WALL-E.
4. Нарешті підрахуйте, скільки разів в тексті було викори- стано слово Earth.
Код до завдання 1:
s = "In a distant, but not so unrealistic, future \
where mankind has abandoned earth because it has \
become covered with trash from products sold by \
the powerful multi-national Buy N Large
corporation, \
WALLE, a garbage collecting robot has been left to \ clean up the mess. Mesmerized with trinkets of Earth's \
history and show tunes, WALLE is alone on Earth except \
1

Домашнє завдання No7
for a sprightly pet cockroach. One day, EVE, a
sleek \
(and dangerous) reconnaissance robot, is sent to
Earth to \
find proof that life is once again sustainable."
# Step 1
len()
# Step 2
?.upper()
# Step 3
?.replace(*, *, *) # Step 4
?.count()
Завдання 2
Напишіть програму, яка дозволить перевіряти пароль на складність. Скористайтеся строковими методами, описаними в розділі 4.7.1. String Methods (https://docs.python.org/3.6/ library/stdtypes.html#str.isupper).
Перевірку пароля слід проводити за такими критеріями:
1. Довжина: від 5 символів.
2. Букви латинського алфавіту у верхньому і нижньому ре- гістрі: A, a, Z, z.
2

Домашнє завдання No7
3. Цифри: від 0 до 9.
4. Символи: @, #, %, &.
Рекомендації
Можете скористатися методом isnumeric()для пере- вірки рядка на наявність цифр. Метод isupper() дозволяє виконати перевірку букв у верхньому регістрі, islower()слід використовувати для перевірки малих літер. В свою чергу, isalpha() дозволить визначити символ в рядку.
Результат роботи: файл з розширенням .py.
Вибір ПЗ на ваш розсуд: Atom, PyCharm, Python IDLE або ін.
3

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
corbaov2018
24.01.2020 10:47

Допустим в 1 доме живет ткачиха. Из этого следует, что во 2-повариха, 3-швея, 4-портниха.

Затем составляшь таблицу следуя из суждений

примерно так:

                повариха        портниха       швея      ткачиха

Маша           -                        +              -                -

 

Даша             -                      -               -                 +

 

Глаша            -                       -                +               -

 

Наташа           +                     -                 -               -

ответ: Даша-ткачиха 

0,0(0 оценок)
Ответ:
artemafanasev2003
25.11.2022 22:55

Тут используется собственная функция для нахождения степени числа.

 

#include <iostream>
using std::cout;
using std::cin;
using std::endl;

int powerFunction(int, int);

int main()
{
   int number, power;

   cout << "Enter A: ";
   cin >> number;
   cout << "Enter N: ";
   cin >> power;

   cout << number << " to the power of " << power
      << " = " << powerFunction(number, power) << endl;

   return 0;
}

int powerFunction(int n, int p)
{
   int temp = 1;

   for(int i = 0; i < p; i++)
   {
      temp *= n;
   }

   return temp;
}


Составить программу вычеслений степени числа а с натуральным показателем n.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота