Крутойбрат
07.07.2020 13:26

Написать программу на джаве


Написать программу на джаве

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Leraleralera151515
09.05.2020 01:51
#include <iostream>
#include <cstring>
#include <vector>
#include <algorithm>

struct StudentData
{
    std::string name;
    std::string surname;
    int math;
    int phys;
    int comp_science;
};

bool
comp(const StudentData &a, const StudentData &b)
{
    int tmp1 = a.math + a.phys + a.comp_science;
    int tmp2 = b.math + b.phys + b.comp_science;
    return tmp1 > tmp2 ? true : false;
}

int
main(void)
{
    int n;
    std::cin >> n;
    std::vector< StudentData > data(n);
    for (int i = 0; i < n; i++) {
        std::cin >> data[i].name >> data[i].surname;
        std::cin >> data[i].math >> data[i].phys >> data[i].comp_science;
    }
    std::sort(data.begin(), data.end(), comp);
    for (int i = 0; i < n; i++) {
        std::cout << data[i].name << " " << data[i].surname << std::endl;
    }
    return 0;
}
0,0(0 оценок)
Ответ:
maxmax41
02.11.2020 22:01
Что такое Интернет и зачем он нужен?

Интернет и его функции

 Интернет – это всемирная компьютерная сеть. Она образует в результате соединения тысяч локальных компьютерных сетей (университетских, региональных и т. д. ), а так же компьютеров, подключённых к сети с отдельных каналов связи.

 Интернет – это огромное информационное пространство. Благодаря объединению ресурсов миллионов компьютеров, размещённых в различных уголках земного шара, сеть Интернет даёт возможность каждому её пользователю получить доступ к необъятным информационным богатством, позволяющим узнавать самые разнообразные сведения – начиная от прогноза погоды в вашем населённом пункте в конкретное время суток и заканчивая серьёзными аналитическими статьями на самые злободневные темы. Кроме чисто информационной функции, сеть Интернет также предоставляет модем множество дополнительных возможностей, позволяющих общаться посредством текстовой, голосовой и даже видеосвязи, загружать на свой компьютер музыку и видеоролики в популярных цифровых форматах (MPEG - 4, MP3), а также многое - многое другое. Бессмысленно пытаться перечислить здесь всё, что может предоставить Интернет своим посетителям, потому что даже пользователи с многолетним стажем обязательно забудут о какой - то важной и интересной возможности – на столько гигантскими по своему количеству и уникальными по своему разнообразию являются доступные в этой сети функции.

 Применение: Синонимами термина «Интернет» являются также слова и словосочетания, как «Глобальная сеть», «Всемирная сеть», «Сеть».
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота