DimaNewPARK
21.11.2022 04:47

Напишите программу Паскаль к двум задачам: 1. Расстояние до ближайшей к Земле звезды Альфа Центавра 4,3 световых года. Скорость света принять за 300.000 км/с. Скорость земного звездолёта 100 км/с . За сколько лет звездолёт долетит до звезды?
2. Документ содержит текст из 32 строк по 60 символов в каждой и точечную черно-белую фотографию 10 × 15 см. Каждый квадратный сантиметр 300 точек, любая точка описывается 4-мя битами. Каков общий информационный объем документа в Кбайтах?

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Matka2002
21.07.2022 18:55

1:

#include<iostream>

#include<vector>

#include<iterator>

#include<ranges>

using namespace std;

int main()

{

   vector<int> vec;

   int sum=0;

   istream_iterator<int> it{cin};

   istream_iterator<int> end{};

   while(it!=end)

   {

       vec.push_back(*it);

       it++;

   }

   for(int i:vec | views::filter([](int i){return i%2==0;}))

   {

       sum+=i;

   }

   cout<<sum<<endl;

   return 0;

}

2:

#include<iostream>

using namespace std;

int main()

{

   int sum=0;

   for(int i=2;i<=32;i+=3)

   {

       sum+=i;

   }

   cout<<sum<<endl;

   return 0;

}

Объяснение:

0,0(0 оценок)
Ответ:
azik55
26.06.2021 07:45

#include <iostream>

using namespace std;

int main()

{

   int a;

   cin >> a;

   if (a > 0)

   {

       a += 1;

   }

   cout << a;

}

Объяснение:

#include <iostream>  // Библиотека ввода - вывода

using namespace std;  // Пространство имен

int main()

{

   int a;  // Создание целочисленной переменной a

   cin >> a;  // Ввод значения переменной a с клавиатуры

   if (a > 0)  // Если значение переменной а > 0

   {

       a += 1;  // К переменной a прибавляем единицу

   }

   cout << a;  // Выводим значение переменной a

}

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота