sentyakovv
05.08.2021 00:26

Написать программу на питоне которая выводит сколько в корзине (гриб,гриба,грибов)


Написать программу на питоне которая выводит сколько в корзине (гриб,гриба,грибов)

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
alima1010
22.01.2022 20:40

Решение 1:

nominative = 1  # окончания им.падеж: гриб

generative = [2, 3, 4]  # список окончаний род.падеж: гриба

plural_generative = [5, 6, 7, 8, 9, 0]  # список окончаний род.падеж множ-го: грибов

for number in range(0, 51):  # цикл с значением от 0 до 51

   """number % 10  возвращает последнюю цифру из числа"""

   if (number % 10) == nominative:  

       print(f"{number} гриб")

   elif (number % 10) in generative:

       print(f"{number} гриба")

   elif (number % 10) in plural_generative:

       print(f"{number} грибов")

Решение 2:

nominative = 1  # окончания им.падеж: гриб

generative = [2, 3, 4]  # список окончаний род.падеж: гриба

for number in range(0, 51):  # цикл с значением от 0 до 51

   """number % 10  возвращает последнию цифру из числа"""

   if (number % 10) == nominative:

       print(f"{number} гриб")

   elif (number % 10) in generative:

       print(f"{number} гриба")

   else:

       print(f"{number} грибов")

Объяснение:

В комментариях.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота