Sanya030814
22.12.2022 04:56

Нужно написать программу на python используя цикл while. (Задача обозначена красным цветом).


Нужно написать программу на python используя цикл while. (Задача обозначена красным цветом).

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
reginaruzova1
16.01.2022 22:40

ok = True

prev = int(input())

cur = prev

while True:

   cur = int(input())

   if cur == 0:

       break

   if (cur > 0 and prev > 0) or (cur < 0 and prev < 0):

       ok = False

   prev = cur

if ok:

   print("YES")

else:

   print("NO")

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота