Сағат
11.10.2021 07:19

5. Составить программу расчета таблицы значений функции f(x) на интервале a<=x<=b в n равностоящих точках. Границы интервала a,b и количество точек n ввести с клавиатуры. Результаты вывести на печать. f(x)=(1-e^(-x))*sin(4pi*x)
Найти сумму вычисленных значений функции f(x), целая часть которых кратна 2.
Программу написать на C++, желательно с комментариями.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Аліна23456
11.08.2022 06:40
#include <iostream>
#include <math.h>
using namespace std;
void main()
{
float p, a, b, c, L, M, H, R_op, R_vp;
cout << "a="; cin>>a;
cout << "b="; cin>>b;
cout << "c="; cin>>c;
p=(a+b+c)/2; //найдём полупериметр
H=(2/a)*sqrt(p*(p-a)*(p-b)*(p-c)); // найдём длину высоты треугольника
M=(1/2)*sqrt(2*a*a+2*b*b-c*c); //найдём длину медианы треугольника
L=(2*sqrt(a*b*p*(p-c)))/(a+b); // найдём длину биссектрисы треугольника
R_op=(a*b*c)/(4*sqrt(p*(p-a)*(p-b)*(p-c))); // найдём радиус описанной окружности треугольника
R_vp=sqrt(((p-a)*(p-b)*(p-c))/p); // найдёи радиус вписанной окружности в треугольник
cout << "Dlina visoti= " << H << endl;
cout << "Dlina mediani= " << M << endl;
cout << "Dlina bissektrisi= " << L << endl;
cout << "Rad.op.okr.= " << R_op << endl;
cout << "Rad.vp.okr.= " << R_vp << endl;
system("PAUSE >> VOID");
}
0,0(0 оценок)
Ответ:
vlad2044
11.08.2022 06:40

Скорее всего тебе необходимы алгоритмы для решения таких задач, они изображаются графически. Прикреплены два файла с этими алгоритмами.

Овалами обозначаются начало и конец алгоритмаТрапеция обозначаются ввод и вывод данныхПрямоугольниками обозначаются блоки где производятся расчеты

Для первой задачи алгоритм прост:

Ввод длины стороны AВвод длины стороны BВвод длины стороны CРасчет длины медианы к стороне AРасчет длины медианы к стороне BРасчет длины медианы к стороне CВывод длины медианы к стороне AВывод длины медианы к стороне BВывод длины медианы к стороне C

Для второй задачи:

Ввод X координаты для первой точкиВвод Y координаты для первой точкиВвод X координаты для второй точкиВвод Y координаты для второй точкиРасчет по формуле расстояния между двумя точками - получаем сторону квадратаРасчет площади квадратаРасчет периметра квадратаВывод значения площади квадратаВывод значения периметра квадрата
Спо программированию , надо решить не по паскалю , а просто . 1)треугольник задан длинами своих стор
Спо программированию , надо решить не по паскалю , а просто . 1)треугольник задан длинами своих стор
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота