Лиза4217
16.06.2020 16:37

Написать программу, которая получает на вход три целых числа (a,b,c) определяет максимальное из них и выводит его в консоль в виде: Max=5

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
torgor2017
15.12.2022 09:19
"((7 - 2 - 2)^2 )^2  - 2 = 79"

#Ruby22
def f0(number, log)
    return [number * number, "(" + log + ")^2 "]
end

def f1(number, log)
    return [number - 2, log + " - 2"]
end

end_num = 79
for n in 1..5
    for i in 0..2**n-1
        s = ("000000000000000000000000000000" + i.to_s(2))[-n..-1]
        start_num = 7
        log = start_num.to_s
        for k in 0..s.size-1

            start_num, log = f0(start_num, log) if s[k] == "0"
            start_num, log = f1(start_num, log) if s[k] == "1"
            # break if start_num > end_num
        end
        # p [start_num, log, s, n]
        if start_num == end_num then
            log += " = " + end_num.to_s
            p log
        end
    end
end
0,0(0 оценок)
Ответ:
ivansndreev1223
05.09.2021 23:49
#include <iostream>
#include <clocale>
using namespace std;
int main() {
setlocale(LC_ALL, "rus");
int a, b, c, min, max;
cout << "Введите первое число: ";
cin >> a;
cout << "Введите второе число: ";
cin >> b;
cout << "Введите третье число: ";
cin >> c;
cout << "\nСумма трех чисел равна: " << a + b + c ;
cout << "\nПроизведение трех чисел равно: " << a * b * c << endl;
if (a > b && a > c) max = a;
  else  if (b > a && b > c) max = b;
   else if (c > a && c > b) max = c;
if (a < b && a < c) min = a;
 else if (b < a && b < c) min = b;
  else if (c < a && c < b) min = c;
cout << "\nМинимальное значение среди трех чисел: " << min;
cout << "\nМаксимальное значение среди трех чисел: " << max << endl;
cout << endl;
system("pause");
return 0;
}
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота