елена1210
29.01.2023 11:39

Дан массив размерностью 6х6 из целых чисел. Напишите программу замены всех отрицательных элементов массива, стоящих на главной диагонали на значение первого элемента массива.(Паскаль)

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
vaxyl
18.08.2020 09:56
PascalABC.NET 3.4.2, сборка 1979 (16.02.2019)

\tt\displaystyle y = 0.5 + \sqrt{x^2 + 1} - tg^2(x^2 + 1)

const  xMin    = 1.5;  xMax    = 2.3;  xDelta  = 0.1; var  x, y, resultSum: real;  valueOfIt: integer; begin  x := xMin;  while x <= xMax do    begin      y := 0.5 + Sqrt(Power(x, 2.0) + 1) - Power(Tan(Power(x, 2.0) + 1), 2.0);      if (y < 0) then        resultSum := resultSum + y;      x := x + xDelta;      valueOfIt := valueOfIt + 1;    end;  Writeln('Среднее отрицательных значений: ', resultSum / valueOfIt); end.ответ

Среднее отрицательных значений: -12.7547010184892

0,0(0 оценок)
Ответ:

Двумя байтами (от 0 до 255) можно записать адрес для 65536 ячеек памяти (от 0 до 65535). Для большего количества ячеек адрес должен иметь больше байтов.

 

Дополнительная информация

ОЗУ обеспечивает режимы записи, считывания и хранения информации, причем в любой момент времени возможен доступ к любой произвольно выбранной ячейки памяти. Принципиальной особенностью ОЗУ является его хранить информацию только во время работы ПК. После загрузки новой программы, прежнее содержимое ОЗУ замещается новым, после выключения ПК пропадает вовсе.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота