Hackerywka
22.09.2021 16:29

напишите программу 1) Последовательность изменяется по закону 2,10,18... Сколько элементов последовательности надо взять, чтобы их сумма была больше 100 2) С клавиатуры вводится 20 чисел. Определите произведение этих чисел, количество положительных, сумму отрицательных элементов заранее

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
woof1337
14.01.2022 06:00

Решение на паскале.

Объяснение:

Первая задача:

var summa, kolichestvo : integer;

 begin

   summa := 2;

   while summa <= 100 do

   begin

     summa := summa + 8;

     kolichestvo := kolichestvo + 1;

   end;

   writeln('Количество = ', kolichestvo);

 end.

Вторая задача:

var a : array[1..20] of integer;

   kolpol, sumot, i : integer;

begin

 for i:=1 to 20 do

   Read(a[i]);

 for i := 1 to 20 do

   if a[i] >= 0 then

     kolpol := kolpol +1

   else

     sumot := sumot + a[i];

 writeln('Количество положительных = ', kolpol);

 writeln('Сумма отрицательных = ', sumot);

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота