xXEliteXx
21.07.2021 20:52

Как написать программу по обмену валют python(₽ в €, € в ₽)

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
07052017
17.12.2022 03:00
//Visual C++ 2012

#include <iostream>
using namespace std;

int main(){
 int ma[2][2];
 int temp;
 temp=0;
 for(int i=0;i<2;i++)
  for(int j=0;j<2;j++)
   cin>>ma[i][j];
 cout<<"First array:"<<endl;
    for (int i=0; i<2; i++){
     for (int j=0; j<2; j++)
      cout<<ma[i][j]<<"\t";
      cout<<endl;
      }
 for(int i=0;i<2;i++){
  temp=ma[i][0];
  ma[i][0]=ma[i][1];
  ma[i][1]=temp;
 }
 cout<<"Final array"<<endl;
    for (int i=0; i<2; i++){
     for (int j=0; j<2; j++)
      cout<<ma[i][j]<<"\t";
      cout<<endl;
      }
 cin.get();
 cin.get();
 return 0;
}
0,0(0 оценок)
Ответ:
AiratAitov
10.12.2021 08:24
1. Уже в первой строке ошибка - отсутствует символ ";" в конце строки.
2. В строке № 8 ошибка, не объявленная переменная "a"

3. Это только ошибки в синтаксисе, после их исправления программа запускается, но работать так как нужно не будет. Ищем ошибки в алгоритме:
исправим стороку "for i := 1 to a do" на "for i := 1 to n do" и получим вывод всех делителей, но в условии задачи требуется вывести и их количество. Вот исправленный код программы:
var
  n, i, a: integer;

begin
  write('введите число');
  read(n);
  writeln('делители');
  for i := 1 to n do
    if n mod i = 0 then begin
      writeln(i); a:=a+1;
    end;
    writeln('Делителей ',a);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота