shevelevaalla
23.10.2020 01:16

Требуется написать программу на любом ЯП f(x) sin(0.5x)-x^2+1
[0; Пи]
h= Пи/5
n1=2
n2=3
Точки x1, x2, x3 для вычисления
значений интерполяционных
многочленов
0.81 1.44 2.81


Требуется написать программу на любом ЯП f(x) sin(0.5x)-x^2+1 [0; Пи] h= Пи/5 n1=2 n2=3 Точки x1, x

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
NeGaTiV4iK1233
24.10.2021 11:38
На каком языке програмирования?
на Java
public class MyClass {
public static void main(String[] args) throws Exception{
BufferedReader reader = new BufferedReader(new InputStreamReader(System.in)));
System.out.println("введите координаты");
System.out.println("x:");
Integer x = Integer.valueOf(reader.println());
System.out.println("y:");
Integer y = Integer.valueOf(reader.println());
Заштрихованая область как определяется?
пусть она уже задана и имеет вид прямоугольника.
int lefiXofSpace = 5;
int rightXofSpace = 10;
int upYof Space = 7;
int downYof Space = 5;
if((x >= leftXofSpace && x <= rightXofSpace) && (y >= downYofSpace && y <= upYofSpace)) {
System.out.printl("Точка попала в заштрихованую область");
} else {
System.out.printl("Точка не попала в заштрихованую область");
}
}
}
0,0(0 оценок)
Ответ:
Галя4425
24.10.2021 11:38
Var
  x,y:real;
begin
  Write('Введите координаты x и y точки: '); Readln(x,y);
  Write('Точка с указанными координатами ');
  if not ((y<=x) and (x<=2) and ((sqr(x)+sqr(y))>=4) and (y>=0)) then
    Write('не ');
  Writeln('принадлежит заштрихованной области.')
end.

Примеры выполнения программы:
Введите координаты x и y точки: 1.9 2.1
Точка с указанными координатами не принадлежит заштрихованной области.

Введите координаты x и y точки: 1.9 1.82
Точка с указанными координатами принадлежит заштрихованной области.

Введите координаты x и y точки: 1 -3
Точка с указанными координатами не принадлежит заштрихованной области.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота