kris411
06.02.2021 18:24

Напишите программу на Python, которая в последовательности целых чисел находит два разных по значению наибольших числа среди чисел не кратных трем


Напишите программу на Python, которая в последовательности целых чисел находит два разных по значени

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Ganshit
12.01.2022 11:00

Программа:

num = int(input("Введите число: "))

data_num = []

while num != 0:

   if num % 3 != 0:

       data_num += [num]

   num = int(input("Введите число: "))

num_max = max(data_num)

print("\nПервое максимальное число:", num_max)

data_num = [el for el in data_num if el != num_max]

print("Второе максимальное число:", max(data_num))

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота