029292299292
05.03.2023 21:02

Написать программу на C++. Вставить новый элемент после последнего положительного.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
simonenkoeliza
11.01.2022 06:00

Решение в лоб:

#include <iostream>

#include <vector>

using namespace std;

int main() {

   vector<int> a(10);

   cout << "Enter array:" <<endl;

   for (int& i : a) {

       cin >> i;

   }

   int m = 0;

   for (int i = 0; i < a.size(); ++i) {

       if (a[i] > 0) {

           m = i + 1;

       }

   }

   cout << "Enter element to insert:" << endl;

   int v;

   cin >> v;

   a.insert(a.begin() + m, v);

   cout << "Result is below:" << endl;

   for(const int& i : a) {

       cout << i << ' ';

   }

   cout << endl;

   return 0;

}

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота